Optimizing TF2

Discussion for Team Fortress 2
This is a Retired branch. Server information no longer applies, except member hosted servers dated 3/12 or later
15 posts Page 1 of 1

Topic author
}SoC{Jarred
Guardian Elder
Posts: 1926
Joined: 12 years ago


Type net_graph 1 into console. If your FPS is below 60, you probably could use a boost. Here's how.

Download an fps config. It will lower your graphics far beyond what you can do through regular settings via the game options. Here is one option as far as a config goes: http://fakkelbrigade.eu/chris/configs/ (I use max frames) There are many others out there, but this is what I use. Basically, what you need to do is copy the config into your tf/config folder. You will also need to add some options to your launch options for TF2.

Your config folder is found in Steam/steamapps/account/team fortress 2/tf.
You can access your launch options by opening steam, right clicking team fortress 2, properties, set launch options.

The readme that accompanies the config will tell you what to put in your launch options. If you have questions about anything, post em and one of our glorious tech geniuses will help ya out. That aint usually my strong point.. :P

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{ZEDD
Clan Member
Posts: 2720
Joined: 10 years ago


I configured mine using my ATI Catalyst Control Center(NVIDIA has a similar program that comes with the card), I just set everything to 'performance' rather than Quality.
I get around 250 FPS in our Pub server(with 3 peeps in it.). :]

Things get too fussy if I set my monitor to 75 hertz, so I'm running at 60 Fps.

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{blkshp
Clan Member
Posts: 1849
Joined: 13 years ago


}SoC{ZEDD wrote:
I configured mine using my ATI Catalyst Control Center(NVIDIA has a similar program that comes with the card), I just set everything to 'performance' rather than Quality.
I get around 250 FPS in our Pub server(with 3 peeps in it.). :]

Things get too fussy if I set my monitor to 75 hertz, so I'm running at 60 Fps.
Did you disable v-sync?

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Kaz
Clan Member
Posts: 1120
Joined: 10 years ago


Stickied because this will be a nice thing to have for those who need the performance boost. :D

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Kyle
Teamspeak Admin
Posts: 384
Joined: 9 years ago


OK...so I download the M0re FPS one and the Setting and Alias one and added the files. Graphics are super bad but FPS "seems" better. HUD is different. But once I installed the configuration files all of my key setting got messed up and I can't see my FPS by typing in "net_graph 1". I type it in and nothing happens. It worked before I inserted the files though.

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Kyle
Teamspeak Admin
Posts: 384
Joined: 9 years ago


OK...so I download the M0re FPS one and the Setting and Alias one and added the files. Graphics are super bad but FPS "seems" better. HUD is different. But once I installed the configuration files all of my key setting got messed up. Every time I start TF2, I have to remap all of my keys. I can't see my FPS by typing in "net_graph 1" anymore. I type it in and nothing happens. It worked before I inserted the files though. Oh, and my in-game sound quality (including voice chat) has become unbearably horrible. I can't understand a word people are saying. :cry:

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{ZEDD
Clan Member
Posts: 2720
Joined: 10 years ago


Did you disable v-sync?
Yep.

Kyle, putting -autoconfig in your launch options should reset your settings, you'll need to get rid of the bad autoexec file first though.

Just check this out;
http://www.gotfrag.com/tf2/forums/thread/322476/
If you screwed up your game with some settings, if you enter:
-autoconfig
in the launch options, and the start the game (and get rid of the offending autoexec before game start) , it will reset all of your options to default.

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Kyle
Teamspeak Admin
Posts: 384
Joined: 9 years ago


-autoconfig doesn't work. It still stays the same. I didn't make a backup copy of the original config files so how to I get them back. I've already completely reinstalled the game and nothing different.

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Shiiben
Teamspeak Admin
Posts: 533
Joined: 12 years ago


I don't have a link, but another example is Quantum's Little Config V2. Its what I'm using, seems to be working well enough.

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Gaetaman
Clan Member
Posts: 13
Joined: 8 years ago


I've always have never seen things such as the flames, medigun beam, or even the glow of the rockets. Now i can thanks these helpful tips you guys gave me. It's like I was blind and now i see.

Only a few things bug me though: i can't see the yellow glow around enemies when they are covered in jarate, no team colored glow while under a kritzkreg (lightening still shows though), no team colored weapon glow under the buff banner (i think, but i can see the feet auras while the buff banner is in effect). Other than these problems the game is soooo much better.

Thanks Soldiers of Christ!

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Choco26
Clan Member
Posts: 28
Joined: 7 years ago


I hate to be a bother, but it seems the top link there (http://www.m0re.nocrits.com/index.php?site=files&cat=1) no longer works. Does anyone know of another place I could find this program? Or of another program that could also help me increase my FPS? Any help is greatly appreciated.

Link:
BBcode:
HTML:
Hide post links
Show post links

Topic author
}SoC{Jarred
Guardian Elder
Posts: 1926
Joined: 12 years ago


I updated the link.

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Tech
Guardian Elder
Posts: 1880
Joined: 13 years ago


For configs you'll want to go to Chris's now, his are much better than m0res!

http://fakkelbrigade.eu/chris/configs/

Link:
BBcode:
HTML:
Hide post links
Show post links

Topic author
}SoC{Jarred
Guardian Elder
Posts: 1926
Joined: 12 years ago


Thanks Tech, I was thinking HUD. I updated the link again!

Link:
BBcode:
HTML:
Hide post links
Show post links

}SoC{Choco26
Clan Member
Posts: 28
Joined: 7 years ago


Thank you both! My TF2 runs a lot better now.

Link:
BBcode:
HTML:
Hide post links
Show post links
15 posts Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests